Compendio de problemas con Eclipse en Ubuntu 9.10

Parece que Ubuntu 9.10 está siendo un quebradero de cabeza para los usuarios de Eclipse. Desde luego, yo me bajo del burro de Ubuntu 9.10 (y me vuelvo al 9.04) antes que bajarme del de Eclipse, no sé vosotros.

La cuestión es que parece haber tres problemas diferentes, que pueden afectar a diferentes versiones de Eclipse, y que pueden darse de manera simultánea, a saber:

  • Puede ser que los botones se comporten de manera errónea: se pueden pulsar, pero no realizan la acción asignada. Al sacar el ratón del botón, éste vuelve a su posición original sin hacer nada de utilidad. Este problema afecta a todas las versiones de Eclipse, y está resuelto a partir de la 3.6M3 y en la 3.5.2 (disponibles aquí). Si no tienes opción de cambiar de versión de Eclipse, porque no quieres una versión en desarrollo o porque necesitas esa en concreto, entonces este problema se puede solventar: a) utilizando el teclado: pulsando Enter se ejecuta la acción asociada al botón seleccionado; b) ejecutando eclipse desde un script que contenga lo siguiente:

  • #!/bin/sh
    export GDK_NATIVE_WINDOWS=1
    /opt/eclipse-3.5/eclipse

  • Puede ser que no se muestran los iconos en los menús de Eclipse. Los menús sin los iconos parecen vacíos. Esta cuestión se solventa activando los iconos en los menús en Ubuntu. Menú Sistema > Preferencias > Apariencia. En la pestaña Interfaz activar la opción “Mostrar iconos en los menús”. Si tienes un Ubuntu en inglés, guess!
  • Puede ser que Eclipse parezca querer arrancar (es muy voluntarioso) pero que el resultado sea un cuadro de diálogo gris (que además no se puede cerrar). Este error yo no lo he sufrido personalmente, pero ha habido gente que me lo han comunicado en relación con EclipseGavab (de esta distribución hablaremos en otro momento). A mi EclipseGavab me funciona perfectamente en Ubuntu 9.10 salvo por los dos problemas anteriores. Este problema se debe al componente SWT Browser y la versión que espera del XULRunner (en el que está basado) que viene instalado en el sistema. Versiones de Eclipse entre la 3.4M5 y la 3.4RC2 requieren versiones de XULRunner anteriores a Mayo. Versiones de Eclipse >= 3.4RC3 requieren versiones de XULRunner posteriores a Mayo:
  • – swt 3.4M5-3.4RC2 with xulrunner 1.9/firefox 3.0 betas from before May
    – swt 3.4RC3 and newer with xulrunner 1.9/firefox 3.0 betas newer than early
    May

    (Fuente: https://bugs.eclipse.org/bugs/show_bug.cgi?id=235020#c2)

    A ver si entre todos evitamos tener que volver al 9.04…

    Update:
    para solucionar el último problema, podéis introducir lo siguiente en el eclipse.ini:
    -Dorg.eclipse.swt.browser.XULRunnerPath=/dev/null

    Anuncios

    Responder

    Introduce tus datos o haz clic en un icono para iniciar sesión:

    Logo de WordPress.com

    Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

    Imagen de Twitter

    Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

    Foto de Facebook

    Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

    Google+ photo

    Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

    Conectando a %s